Wtyczki: PHP Compatibility Checker

Szacunkowy czas czytania: 2 minuty

 

Niniejszym wpisem inauguruję serię postów-recenzji wtyczek. Będę opisywać wtyczki, które sama przetestowałam na swojej stronie i innych stronach, które tworzę lub tworzyłam.

PHP Compatibility Checker – WordPress

  • ponad 40 tysięcy aktywnych instalacji
  • kompatybilna z wersją 4.9.4. WordPressa
  • minimalna wymagana wersja WP to 3.5
  • ocena na wordpress.org – 3,5/5
  • strona na wordpress.org

Do czego służy ?

Wtyczka skanuje kod motywu i wtyczek, a następnie generuje raport na temat kompatybilności tych elementów z wersją PHP wybraną przed skanowaniem. Wersje PHP do wyboru: 7.0, 7.1, 7.2. Można wybrać pełny skan, albo skan tylko aktywnych motywów i wtyczek. Tutaj warto dodać, że ze względów bezpieczeństwa nieaktywne motywy i wtyczki nie powinny w ogóle znajdować się na naszej stronie.

PHP Compatibility Checker wskazuje co jest do poprawy, które linijki kodu mogą być problematyczne, a także które wtyczki należy uaktualnić.

Moja recenzja

Wtyczka jest przydatna. Można z niej korzystać doraźnie, tzn. zainstalować, przeskanować system i ją następnie odinstalować. Raport jest czytelny i prosty z funkcją pobrania w pliku .txt. Wtyczka nie radzi sobie z cięższymi elementami, np. nie dała rady przeskanować Akeeba Backup – wtyczki do tworzenia kopii zapasowych i migracji stron.

Wtyczka może pomóc znaleźć słabe punkty na stronie, jak również wskazać elementy, które należy zmienić przed przejściem z PHP 5.6 (i niższego) na PHP 7.0 i wyższe. Pamiętajcie, że wersje 5.6 i 7.0 przestaną być wspierane w grudniu 2018, więc już dziś warto się na to przygotować.

Jeden komentarz

  1. Pingback:Strona na Wordpressie a wersje PHP | Katarzyna Javaheri-Szpak

Możliwość komentowania została wyłączona.